<!DOCTYPE html>
<html class="no-js mh-disable-sb fullbg" lang="en-US">
<head>
<!-- Global site tag (gtag.js) - Google Analytics -->
<script async src="https://www.googletagmanager.com/gtag/js?id=UA-113793554-1"></script>
<script>
  window.dataLayer = window.dataLayer || [];
  function gtag(){dataLayer.push(arguments);}
  gtag('js', new Date());

  gtag('config', 'UA-113793554-1');
</script>`
<meta charset="UTF-8">
<meta name="viewport" content="width=device-width, initial-scale=1.0">
<link rel="profile" href="http://gmpg.org/xfn/11" />
<title>Rhye releases full-length &#039;Blood&#039; | WRBB 104.9 FM</title>

<!-- All in One SEO Pack 2.4.3 by Michael Torbert of Semper Fi Web Design[557,631] -->
<meta name="description"  content="Rhye Blood Loma Vista Recordings · February 2, 2018" />

<meta name="keywords"  content="album review,blood,rhye" />

<link rel="canonical" href="http://wrbbradio.org/2018/02/20/rhye-releases-full-length-blood/" />
<!-- /all in one seo pack -->
<link rel='dns-prefetch' href='//s0.wp.com' />
<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="WRBB 104.9 FM &raquo; Feed" href="http://wrbbradio.org/feed/" />
<link rel="alternate" type="application/rss+xml" title="WRBB 104.9 FM &raquo; Comments Feed" href="http://wrbbradio.org/comments/feed/" />
<link rel="alternate" type="application/rss+xml" title="WRBB 104.9 FM &raquo; Rhye releases full-length &#8216;Blood&#8217; Comments Feed" href="http://wrbbradio.org/2018/02/20/rhye-releases-full-length-blood/feed/" />
		<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/2.3\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/2.3\/svg\/","svgExt":".svg","source":{"concatemoji":"http:\/\/wrbbradio.org\/wp-includes\/js\/wp-emoji-release.min.js?ver=4.8.5"}};
			!function(a,b,c){function d(a){var b,c,d,e,f=String.fromCharCode;if(!k||!k.fillText)return!1;switch(k.clearRect(0,0,j.width,j.height),k.textBaseline="top",k.font="600 32px Arial",a){case"flag":return k.fillText(f(55356,56826,55356,56819),0,0),b=j.toDataURL(),k.clearRect(0,0,j.width,j.height),k.fillText(f(55356,56826,8203,55356,56819),0,0),c=j.toDataURL(),b!==c&&(k.clearRect(0,0,j.width,j.height),k.fillText(f(55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447),0,0),b=j.toDataURL(),k.clearRect(0,0,j.width,j.height),k.fillText(f(55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447),0,0),c=j.toDataURL(),b!==c);case"emoji4":return k.fillText(f(55358,56794,8205,9794,65039),0,0),d=j.toDataURL(),k.clearRect(0,0,j.width,j.height),k.fillText(f(55358,56794,8203,9794,65039),0,0),e=j.toDataURL(),d!==e}return!1}function e(a){var c=b.createElement("script");c.src=a,c.defer=c.type="text/javascript",b.getElementsByTagName("head")[0].appendChild(c)}var f,g,h,i,j=b.createElement("canvas"),k=j.getContext&&j.getContext("2d");for(i=Array("flag","emoji4"),c.supports={everything:!0,everythingExceptFlag:!0},h=0;h<i.length;h++)c.supports[i[h]]=d(i[h]),c.supports.everything=c.supports.everything&&c.supports[i[h]],"flag"!==i[h]&&(c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&c.supports[i[h]]);c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&!c.supports.flag,c.DOMReady=!1,c.readyCallback=function(){c.DOMReady=!0},c.supports.everything||(g=function(){c.readyCallback()},b.addEventListener?(b.addEventListener("DOMContentLoaded",g,!1),a.addEventListener("load",g,!1)):(a.attachEvent("onload",g),b.attachEvent("onreadystatechange",function(){"complete"===b.readyState&&c.readyCallback()})),f=c.source||{},f.concatemoji?e(f.concatemoji):f.wpemoji&&f.twemoji&&(e(f.twemoji),e(f.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
<link rel='stylesheet' id='avatar-manager-css'  href='http://wrbbradio.org/wp-content/plugins/avatar-manager/assets/css/avatar-manager.min.css?ver=1.2.1' type='text/css' media='all' />
<link rel='stylesheet' id='cpsh-shortcodes-css'  href='http://wrbbradio.org/wp-content/plugins/column-shortcodes//assets/css/shortcodes.css?ver=1.0' type='text/css' media='all' />
<link rel='stylesheet' id='mh-magazine-css'  href='http://wrbbradio.org/wp-content/themes/mh-magazine/style.css?ver=3.5.0' type='text/css' media='all' />
<link rel='stylesheet' id='mh-font-awesome-css'  href='http://wrbbradio.org/wp-content/themes/mh-magazine/includes/font-awesome.min.css' type='text/css' media='all' />
<link rel='stylesheet' id='mh-google-fonts-css'  href='https://fonts.googleapis.com/css?family=Lato:300,400,400italic,600,700' type='text/css' media='all' />
<!-- Inline jetpack_facebook_likebox -->
<style id='jetpack_facebook_likebox-inline-css' type='text/css'>
.widget_facebook_likebox {
	overflow: hidden;
}

</style>
<link rel='stylesheet' id='mc4wp-form-basic-css'  href='http://wrbbradio.org/wp-content/plugins/mailchimp-for-wp/assets/css/form-basic.min.css?ver=4.1.11' type='text/css' media='all' />
<link rel='stylesheet' id='msl-main-css'  href='http://wrbbradio.org/wp-content/plugins/master-slider/public/assets/css/masterslider.main.css?ver=3.1.6' type='text/css' media='all' />
<link rel='stylesheet' id='msl-custom-css'  href='http://wrbbradio.org/wp-content/uploads/master-slider/custom.css?ver=5.1' type='text/css' media='all' />
<link rel='stylesheet' id='jetpack_css-css'  href='http://wrbbradio.org/wp-content/plugins/jetpack/css/jetpack.css?ver=5.5.1' type='text/css' media='all' />
<script type='text/javascript'>
/* <![CDATA[ */
var SDT_DATA = {"ajaxurl":"http:\/\/wrbbradio.org\/wp-admin\/admin-ajax.php","siteUrl":"http:\/\/wrbbradio.org\/","pluginsUrl":"http:\/\/wrbbradio.org\/wp-content\/plugins","isAdmin":""};
/* ]]> */
</script>
<script type='text/javascript' src='http://wrbbradio.org/wp-includes/js/jquery/jquery.js?ver=1.12.4'></script>
<script type='text/javascript' src='http://wrbbradio.org/wp-includes/js/jquery/jquery-migrate.min.js?ver=1.4.1'></script>
<script type='text/javascript' src='http://wrbbradio.org/wp-content/plugins/ajaxify-wordpress-site/js/history.js?ver=4.8.5'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var aws_data = {"rootUrl":"http:\/\/wrbbradio.org\/","ids":"","container_id":"main-content","mcdc":"menu-menu-1-container","searchID":"search-form","transition":"","scrollTop":"","loader":"ajax-loader-blue.gif","bp_status":""};
/* ]]> */
</script>
<script type='text/javascript' src='http://wrbbradio.org/wp-content/plugins/ajaxify-wordpress-site/js/ajaxify.js?ver=4.8.5'></script>
<script type='text/javascript' src='http://wrbbradio.org/wp-content/plugins/avatar-manager/assets/js/avatar-manager.min.js?ver=1.2.1'></script>
<script type='text/javascript' src='http://wrbbradio.org/wp-content/plugins/wonderplugin-audio/engine/wonderpluginaudioskins.js?ver=5.2'></script>
<script type='text/javascript' src='http://wrbbradio.org/wp-content/plugins/wonderplugin-audio/engine/wonderpluginaudio.js?ver=5.2'></script>
<script type='text/javascript' src='http://wrbbradio.org/wp-content/themes/mh-magazine/js/scripts.js?ver=4.8.5'></script>
<link rel='https://api.w.org/' href='http://wrbbradio.org/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="http://wrbbradio.org/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="http://wrbbradio.org/wp-includes/wlwmanifest.xml" /> 
<link rel='prev' title='New Music Mondays | 02.19.18' href='http://wrbbradio.org/2018/02/19/new-music-mondays-02-19-18/' />
<meta name="generator" content="WordPress 4.8.5" />
<link rel='shortlink' href='https://wp.me/p460Br-1X4' />
<link rel="alternate" type="application/json+oembed" href="http://wrbbradio.org/wp-json/oembed/1.0/embed?url=http%3A%2F%2Fwrbbradio.org%2F2018%2F02%2F20%2Frhye-releases-full-length-blood%2F" />
<link rel="alternate" type="text/xml+oembed" href="http://wrbbradio.org/wp-json/oembed/1.0/embed?url=http%3A%2F%2Fwrbbradio.org%2F2018%2F02%2F20%2Frhye-releases-full-length-blood%2F&#038;format=xml" />
<script>var ms_grabbing_curosr = 'http://wrbbradio.org/wp-content/plugins/master-slider/public/assets/css/common/grabbing.cur', ms_grab_curosr = 'http://wrbbradio.org/wp-content/plugins/master-slider/public/assets/css/common/grab.cur';</script>
<meta name="generator" content="MasterSlider 3.1.6 - Responsive Touch Image Slider | avt.li/msf" />

<link rel='dns-prefetch' href='//v0.wordpress.com'/>
<link rel='dns-prefetch' href='//i0.wp.com'/>
<link rel='dns-prefetch' href='//i1.wp.com'/>
<link rel='dns-prefetch' href='//i2.wp.com'/>
<style type="text/css">
.mh-widget-layout4 .mh-widget-title { background: #dd3333; background: rgba(221, 51, 51, 0.6); }
.mh-preheader, .mh-wide-layout .mh-subheader, .mh-ticker-title, .mh-main-nav li:hover, .mh-footer-nav, .slicknav_menu, .slicknav_btn, .slicknav_nav .slicknav_item:hover, .slicknav_nav a:hover, .mh-back-to-top, .mh-subheading, .entry-tags .fa, .entry-tags li:hover, .mh-widget-layout2 .mh-widget-title, .mh-widget-layout4 .mh-widget-title-inner, .mh-widget-layout4 .mh-footer-widget-title, #mh-mobile .flex-control-paging li a.flex-active, .mh-image-caption, .mh-carousel-layout1 .mh-carousel-caption, .mh-tab-button.active, .mh-tab-button.active:hover, .mh-footer-widget .mh-tab-button.active, .mh-social-widget li:hover a, .mh-footer-widget .mh-social-widget li a, .mh-footer-widget .mh-author-bio-widget, .tagcloud a:hover, .mh-widget .tagcloud a:hover, .mh-footer-widget .tagcloud a:hover, .mh-posts-stacked-meta, .page-numbers:hover, .mh-loop-pagination .current, .mh-comments-pagination .current, .pagelink, a:hover .pagelink, input[type=submit], #infinite-handle span { background: #dd3333; }
.mh-main-nav-wrap .slicknav_nav ul, blockquote, .mh-widget-layout1 .mh-widget-title, .mh-widget-layout3 .mh-widget-title, #mh-mobile .mh-slider-caption, .mh-carousel-layout1, .mh-spotlight-widget, .mh-author-bio-widget, .mh-author-bio-title, .mh-author-bio-image-frame, .mh-video-widget, .mh-tab-buttons, .bypostauthor .mh-comment-meta, textarea:hover, input[type=text]:hover, input[type=email]:hover, input[type=tel]:hover, input[type=url]:hover { border-color: #dd3333; }
.mh-dropcap, .mh-carousel-layout1 .flex-direction-nav a, .mh-carousel-layout2 .mh-carousel-caption, .mh-posts-digest-small-category, .mh-posts-lineup-more, .bypostauthor .mh-comment-meta-author:after, .mh-comment-meta-links .comment-reply-link:before, #respond #cancel-comment-reply-link:before { color: #dd3333; }
.mh-meta, .mh-meta a, .mh-breadcrumb, .mh-breadcrumb a, .mh-user-data, .widget_rss .rss-date, .widget_rss cite { color: #2d2d2d; }
.entry-content a, .mh-comment-content a { color: #dd3333; }
a:hover, .entry-content a:hover, .mh-comment-content a:hover, #respond a:hover, .mh-meta a:hover, .mh-breadcrumb a:hover, .mh-tabbed-widget a:hover { color: #dd3333; }
</style>
<!--[if lt IE 9]>
<script src="http://wrbbradio.org/wp-content/themes/mh-magazine/js/css3-mediaqueries.js"></script>
<![endif]-->
<style type="text/css">
h1, h2, h3, h4, h5, h6, .mh-custom-posts-small-title { font-family: "Lato", sans-serif; }
body { font-family: "Lato", sans-serif; }
</style>
<style type="text/css">/* MailChimp for WP - Checkbox Styles */
.mc4wp-checkbox-wp-comment-form {
  clear: both;
  display: block;
  position: static;
  width: auto; }
  .mc4wp-checkbox-wp-comment-form input {
    float: none;
    width: auto;
    position: static;
    margin: 0 6px 0 0;
    padding: 0;
    vertical-align: middle;
    display: inline-block !important;
    max-width: 21px;
    -webkit-appearance: checkbox; }
  .mc4wp-checkbox-wp-comment-form label {
    float: none;
    display: block;
    cursor: pointer;
    width: auto;
    position: static;
    margin: 0 0 16px 0; }
</style><style type="text/css">/* MailChimp for WP - Checkbox Styles */
.mc4wp-checkbox-wp-registration-form {
  clear: both;
  display: block;
  position: static;
  width: auto; }
  .mc4wp-checkbox-wp-registration-form input {
    float: none;
    width: auto;
    position: static;
    margin: 0 6px 0 0;
    padding: 0;
    vertical-align: middle;
    display: inline-block !important;
    max-width: 21px;
    -webkit-appearance: checkbox; }
  .mc4wp-checkbox-wp-registration-form label {
    float: none;
    display: block;
    cursor: pointer;
    width: auto;
    position: static;
    margin: 0 0 16px 0; }
</style><style type="text/css" id="custom-background-css">
body.custom-background { background-color: #d3d3d3; background-image: url("http://wrbbradio.org/wp-content/uploads/2017/10/37076508716_de07071e86_o-min-min-2.jpg"); background-position: left top; background-size: auto; background-repeat: no-repeat; background-attachment: fixed; }
</style>

<!-- Jetpack Open Graph Tags -->
<meta property="og:type" content="article" />
<meta property="og:title" content="Rhye releases full-length &#8216;Blood&#8217;" />
<meta property="og:url" content="http://wrbbradio.org/2018/02/20/rhye-releases-full-length-blood/" />
<meta property="og:description" content="Rhye Blood Loma Vista Recordings · February 2, 2018" />
<meta property="article:published_time" content="2018-02-20T13:00:25+00:00" />
<meta property="article:modified_time" content="2018-02-19T21:02:14+00:00" />
<meta property="og:site_name" content="WRBB 104.9 FM" />
<meta property="og:image" content="https://i1.wp.com/wrbbradio.org/wp-content/uploads/2018/02/Screen-Shot-2018-02-12-at-12.28.13-PM-1518456520-640x640.png?fit=640%2C640" />
<meta property="og:image:width" content="640" />
<meta property="og:image:height" content="640" />
<meta property="og:locale" content="en_US" />
<meta name="twitter:text:title" content="Rhye releases full-length &#8216;Blood&#8217;" />
<meta name="twitter:image" content="https://i1.wp.com/wrbbradio.org/wp-content/uploads/2018/02/Screen-Shot-2018-02-12-at-12.28.13-PM-1518456520-640x640.png?fit=640%2C640&#038;w=640" />
<meta name="twitter:card" content="summary_large_image" />
<link rel="icon" href="https://i0.wp.com/wrbbradio.org/wp-content/uploads/2017/01/cropped-Logo_final_social.jpg?fit=32%2C32" sizes="32x32" />
<link rel="icon" href="https://i0.wp.com/wrbbradio.org/wp-content/uploads/2017/01/cropped-Logo_final_social.jpg?fit=192%2C192" sizes="192x192" />
<link rel="apple-touch-icon-precomposed" href="https://i0.wp.com/wrbbradio.org/wp-content/uploads/2017/01/cropped-Logo_final_social.jpg?fit=180%2C180" />
<meta name="msapplication-TileImage" content="https://i0.wp.com/wrbbradio.org/wp-content/uploads/2017/01/cropped-Logo_final_social.jpg?fit=270%2C270" />
			<style type="text/css" id="wp-custom-css">
				/*
Welcome to Custom CSS!

To learn how this works, see http://wp.me/PEmnE-Bt
*/
#jp_container_2.jp-audio.wpallaudio {
	max-width: 99%;
}

#widget-box {
	font-family: 'Roboto Condensed', sans-serif;
	padding: 1em;
	background: #FFFABC;
	width: 40%;
}

#widget-box h1 {
	font-weight: normal;
	font-size: 1.4em;
}

#np-cont {
	width: 100%;
	max-width: 1080px;
	margin: 0 auto;
	position: fixed;
	bottom: 0;
	z-index: 999999;
}

#np {
	width: 3%;
	height: 40px;
	background-color: white;
	position: relative;
	float: right;
	border-top: 1px solid #cbcbcb;
}

#caret {
	position: relative;
}

.diskpart, .spunpart {
	display: none;
}

#spinitron-nowplaying {
	line-height: 36px;
}

/* Styling for new music mondays tables */
.nmm-table {
	border: none;
}

.nmm-table td {
	border-bottom: solid 1px black;
	border-right: none;
}

/* Gets rid of Author photo */
.mh-author-box-avatar {
	display: none;
}

/* Makes schedule iFrame responsive */
.schedule-container {
	position: relative;
	padding-bottom: 75%;
	width: 1030px;
	height: 0;
	overflow: auto;
}

.schedule-container iframe {
	position: absolute;
	top: 0;
	left: 0;
	width: 100%;
	height: 100%;
}			</style>
		</head>
<body id="mh-mobile" class="post-template-default single single-post postid-7506 single-format-standard custom-background _masterslider _ms_version_3.1.6 mh-boxed-layout mh-right-sb mh-loop-layout1 mh-widget-layout3 mh-header-transparent" itemscope="itemscope" itemtype="http://schema.org/WebPage">
<div class="mh-container mh-container-outer">
<div class="mh-header-nav-mobile clearfix"></div>
	<div class="mh-preheader">
    	<div class="mh-container mh-container-inner mh-row clearfix">
							<div class="mh-header-bar-content mh-header-bar-top-left mh-col-2-3 clearfix">
									</div>
										<div class="mh-header-bar-content mh-header-bar-top-right mh-col-1-3 clearfix">
									</div>
					</div>
	</div>
<header class="mh-header" itemscope="itemscope" itemtype="http://schema.org/WPHeader">
	<div class="mh-container mh-container-inner clearfix">
		<div class="mh-custom-header clearfix">
<a class="mh-header-image-link" href="http://wrbbradio.org/" title="WRBB 104.9 FM" rel="home">
<img class="mh-header-image" src="http://www.wrbbradio.org/wp-content/uploads/2016/10/cropped-cropped-WRBB-Banner.png" height="180" width="1169" alt="WRBB 104.9 FM" />
</a>
</div>
	</div>
	<div class="mh-main-nav-wrap">
		<nav class="mh-navigation mh-main-nav mh-container mh-container-inner clearfix" role="navigation" itemscope="itemscope" itemtype="http://schema.org/SiteNavigationElement">
			<div class="menu-menu-1-container"><ul id="menu-menu-1" class="menu"><li id="menu-item-5402" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-5402"><a href="#">On-Air</a>
<ul  class="sub-menu">
	<li id="menu-item-7344" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-7344"><a href="http://wrbbradio.org/schedule/">On-Air Schedule</a></li>
	<li id="menu-item-4810" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-4810"><a href="http://wrbbradio.org/dj-report-form/">DJ Report Form</a></li>
</ul>
</li>
<li id="menu-item-5349" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-5349"><a href="#">Features</a>
<ul  class="sub-menu">
	<li id="menu-item-5350" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-5350"><a href="http://wrbbradio.org/category/interview/">Interviews</a></li>
	<li id="menu-item-5996" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-5996"><a href="http://wrbbradio.org/category/editorials/">Editorials</a></li>
	<li id="menu-item-5918" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-5918"><a href="http://wrbbradio.org/category/new-music-mondays/">New Music Mondays</a></li>
	<li id="menu-item-5400" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-5400"><a href="http://wrbbradio.org/category/playlists/">Playlists</a></li>
	<li id="menu-item-4108" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-4108"><a href="http://wrbbradio.org/category/photos/">Photos</a></li>
</ul>
</li>
<li id="menu-item-5403" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-5403"><a href="#">Reviews</a>
<ul  class="sub-menu">
	<li id="menu-item-4104" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-4104"><a href="http://wrbbradio.org/category/album-review/">Album Reviews</a></li>
	<li id="menu-item-4103" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-4103"><a href="http://wrbbradio.org/category/show-review/">Show Reviews</a></li>
	<li id="menu-item-4105" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-4105"><a href="http://wrbbradio.org/category/single-review/">Single Reviews</a></li>
</ul>
</li>
<li id="menu-item-5445" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-5445"><a target="_blank" href="http://www.wrbbsports.com/">WRBB Sports</a></li>
<li id="menu-item-5404" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-5404"><a href="#">Get Involved</a>
<ul  class="sub-menu">
	<li id="menu-item-60" class="menu-item menu-item-type-post_type menu-item-object-page current-post-parent menu-item-60"><a href="http://wrbbradio.org/membership/">Becoming a Member</a></li>
	<li id="menu-item-7256" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-7256"><a href="http://wrbbradio.org/showrequest/">Show Request Form</a></li>
	<li id="menu-item-4809" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-4809"><a href="http://wrbbradio.org/dj-request-form/">Event DJ Request Form</a></li>
	<li id="menu-item-64" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-64"><a href="http://wrbbradio.org/station-info-2/">About Us</a></li>
</ul>
</li>
<li id="menu-item-59" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-59"><a href="http://wrbbradio.org/contact/">Contact Us</a></li>
</ul></div>		</nav>
	</div>
	</header>
	<div class="mh-subheader">
		<div class="mh-container mh-container-inner mh-row clearfix">
							<div class="mh-header-bar-content mh-header-bar-bottom-left mh-col-2-3 clearfix">
											<div class="mh-header-date mh-header-date-bottom">
							February 20, 2018						</div>
									</div>
										<div class="mh-header-bar-content mh-header-bar-bottom-right mh-col-1-3 clearfix">
											<aside class="mh-header-search mh-header-search-bottom">
							<form role="search" method="get" class="search-form" action="http://wrbbradio.org/">
				<label>
					<span class="screen-reader-text">Search for:</span>
					<input type="search" class="search-field" placeholder="Search &hellip;" value="" name="s" />
				</label>
				<input type="submit" class="search-submit" value="Search" />
			</form>						</aside>
									</div>
					</div>
	</div>
<div class="mh-wrapper clearfix">
	<div class="mh-main clearfix">
		<div id="main-content" class="mh-content" role="main" itemprop="mainContentOfPage"><nav class="mh-breadcrumb"><span itemscope itemtype="http://data-vocabulary.org/Breadcrumb"><a href="http://wrbbradio.org" itemprop="url"><span itemprop="title">Home</span></a></span><span class="mh-breadcrumb-delimiter"><i class="fa fa-angle-right"></i></span><span itemscope itemtype="http://data-vocabulary.org/Breadcrumb"><a href="http://wrbbradio.org/category/album-review/" itemprop="url"><span itemprop="title">Album Reviews</span></a></span><span class="mh-breadcrumb-delimiter"><i class="fa fa-angle-right"></i></span>Rhye releases full-length &#8216;Blood&#8217;</nav>
<article id="post-7506" class="post-7506 post type-post status-publish format-standard has-post-thumbnail hentry category-album-review category-featured category-recent tag-album-review tag-blood tag-rhye">
	<header class="entry-header clearfix"><h1 class="entry-title">Rhye releases full-length &#8216;Blood&#8217;</h1><p class="mh-meta entry-meta">
<span class="entry-meta-date updated"><i class="fa fa-clock-o"></i><a href="http://wrbbradio.org/2018/02/">February 20, 2018</a></span>
<span class="entry-meta-author author vcard"><i class="fa fa-user"></i><a class="fn" href="http://wrbbradio.org/author/grant-foskett/">Grant Foskett</a></span>
<span class="entry-meta-categories"><i class="fa fa-folder-open-o"></i><a href="http://wrbbradio.org/category/album-review/" rel="category tag">Album Reviews</a>, <a href="http://wrbbradio.org/category/featured/" rel="category tag">Featured</a>, <a href="http://wrbbradio.org/category/recent/" rel="category tag">Recent</a></span>
</p>
	</header>
		<div class="entry-content clearfix">
<figure class="entry-thumbnail">
<img src="https://i1.wp.com/wrbbradio.org/wp-content/uploads/2018/02/Screen-Shot-2018-02-12-at-12.28.13-PM-1518456520-640x640.png?resize=640%2C438" alt="" title="Screen-Shot-2018-02-12-at-12.28.13-PM-1518456520-640x640" />
</figure>
<div class="mh-social-top">
<div class="mh-share-buttons clearfix">
	<a class="mh-facebook" href="#" onclick="window.open('https://www.facebook.com/sharer.php?u=http://wrbbradio.org/2018/02/20/rhye-releases-full-length-blood/&t=Rhye releases full-length &#8216;Blood&#8217;', 'facebookShare', 'width=626,height=436'); return false;" title="Share on Facebook">
		<span class="mh-share-button"><i class="fa fa-facebook"></i></span>
	</a>
	<a class="mh-twitter" href="#" onclick="window.open('https://twitter.com/share?text=Rhye releases full-length &#8216;Blood&#8217; -&url=http://wrbbradio.org/2018/02/20/rhye-releases-full-length-blood/', 'twitterShare', 'width=626,height=436'); return false;" title="Tweet This Post">
		<span class="mh-share-button"><i class="fa fa-twitter"></i></span>
	</a>
	<a class="mh-pinterest" href="#" onclick="window.open('https://pinterest.com/pin/create/button/?url=http://wrbbradio.org/2018/02/20/rhye-releases-full-length-blood/&media=http://wrbbradio.org/wp-content/uploads/2018/02/Screen-Shot-2018-02-12-at-12.28.13-PM-1518456520-640x640.png&description=Rhye releases full-length &#8216;Blood&#8217;', 'pinterestShare', 'width=750,height=350'); return false;" title="Pin This Post">
		<span class="mh-share-button"><i class="fa fa-pinterest"></i></span>
	</a>
	<a class="mh-googleplus" href="#" onclick="window.open('https://plusone.google.com/_/+1/confirm?hl=en-US&url=http://wrbbradio.org/2018/02/20/rhye-releases-full-length-blood/', 'googleShare', 'width=626,height=436'); return false;" title="Share on Google+" target="_blank">
		<span class="mh-share-button"><i class="fa fa-google-plus"></i></span>
	</a>
	<a class="mh-email" href="mailto:?subject=Rhye releases full-length &#8216;Blood&#8217;&amp;body=http://wrbbradio.org/2018/02/20/rhye-releases-full-length-blood/" title="Send this article to a friend" target="_blank">
		<span class="mh-share-button"><i class="fa fa-envelope-o"></i></span>
	</a>
</div></div>
<h2 style="text-align: center;">Rhye<br />
<i>Blood</i></h2>
<h3 style="text-align: center;">Loma Vista Recordings <em>· </em>February 2, 2018</h3>
<p><img class=" wp-image-7473 aligncenter" src="https://i1.wp.com/wrbbradio.org/wp-content/uploads/2018/02/3-Stars-2.png?resize=273%2C103" alt="" srcset="https://i1.wp.com/wrbbradio.org/wp-content/uploads/2018/02/3-Stars-2.png?w=1024 1024w, https://i1.wp.com/wrbbradio.org/wp-content/uploads/2018/02/3-Stars-2.png?resize=300%2C113 300w" sizes="(max-width: 273px) 100vw, 273px" data-recalc-dims="1" /></p>
<hr />
<div class='content-column three_fourth'><p>Rhye is the R&amp;B project of singer Mike Milosh, who released debut album <em>Woman</em> under the name with producer Robin Hannibal in 2013. Hannibal has since left the group, leaving sole creative direction to Milosh, who immediately stands out to many due to his vocals. Milosh’s voice is intentionally soft and feminine, as the project is an exploration of love and sexuality, and is in many ways a love letter to the woman who appears on <em>Blood</em>’s cover. Despite its best intentions though, <em>Blood</em> falls short of the pure magic its history promises.</p>
<p><em>Blood</em> is undeniably very beautiful; from Milosh’s gliding voice to the delicate horns and strings, the album sounds lavish to the point of lascivity. There are certainly imperfections to Milosh’s airy voice and occasionally the arrangements fall short of being the perfect complement, but for the most part, <em>Blood</em> is instrumentally diverse and smooth. For an example of a song where everything went right, look no further than single ‘Please.’ The sparse piano perfectly combines with steady clapping to accent Milosh’s voice, which here is at its best. The subdued chorus highlights his pained yet saccharine delivery in a way that blurs the line between singing and beautifully moaning. ‘Phoenix,’ is also one of the most ambitious compositions Rhye has undertaken, as everything from the beginning bass line to the slick guitar riffs shows instrumental growth from <em>Woman’s</em> often more synthetic sound.</p>
<p>Given this acknowledgement of its beauty, <em>Blood</em> falls short in one very important area: lyrically, it’s either corny or boring. The consistent subject matter of the album is love and sexuality, something that’s been absolutely beat to death by musicians over the last century. Not to say that someone cannot imbue the topic with new life and energy, but that someone is not Milosh. His description of love and sex is defined by surface level descriptions or awkward double entendres. On ‘Taste,’ Milosh refrains “I’ll lick your wounds / I’ll lay you down” like its a profound description. On ‘Softly,’ and every other track, he falls back on the all-too-played-out double meaning of “come” with “I really want you to come with me, ooh.” Overall, the lyrics just never live up to the grace and lavishness promised by the instrumentals and Milosh’s voice. This shallowness often undermines the intricacies of real love, and not to poke into Milosh’s personal life, but it is important to note that he broke up with his wife to which <em>Woman </em>was dedicated to during Rhye’s hiatus. <em>Blood</em> comes more as a portrait of lust, completely debasing the wide-eyed innocence towards love implored on <em>Woman. </em>There is a defense to be made of this devolution, but Milosh comes off as far too myopic to nuance the fine line he blurs between love and lust.</p>
<p>Rhye is certainly interesting in concept. Milosh wants to use his androgyny to accentuate a unique point of view of love and sex. But too often on <em>Blood</em>, he fails to fully utilize this potential and regresses to basic and animalistic depictions of such a complicated topic. No matter how orgasmic the instrumentals can be, when Milosh fails to provide any interesting subject matter, the whole project falls flat.</p>
<p>&nbsp;</p></div>
<div class='content-column one_fourth'><h4 style="text-align: center;">Listen to <em>Blood</em><i> </i>here:<br />
<iframe src="https://open.spotify.com/embed?uri=spotify:album:6yoGOJsTjU7w2amKcUUX7S" width="300" height="380" frameborder="0"></iframe><br /></div></h4>
	</div>
	<div class="entry-tags clearfix"><i class="fa fa-tag"></i><ul><li><a href="http://wrbbradio.org/tag/album-review/" rel="tag">Album Review</a></li><li><a href="http://wrbbradio.org/tag/blood/" rel="tag">Blood</a></li><li><a href="http://wrbbradio.org/tag/rhye/" rel="tag">Rhye</a></li></ul></div>	</article><nav class="mh-post-nav mh-row clearfix" role="navigation">
<div class="mh-col-1-2 mh-post-nav-item mh-post-nav-prev">
<a href="http://wrbbradio.org/2018/02/19/new-music-mondays-02-19-18/" rel="prev"><img width="80" height="60" src="https://i0.wp.com/wrbbradio.org/wp-content/uploads/2018/02/FullSizeRender-2.jpg?resize=80%2C60" class="attachment-mh-magazine-small size-mh-magazine-small wp-post-image" alt="" srcset="https://i0.wp.com/wrbbradio.org/wp-content/uploads/2018/02/FullSizeRender-2.jpg?resize=678%2C509 678w, https://i0.wp.com/wrbbradio.org/wp-content/uploads/2018/02/FullSizeRender-2.jpg?resize=326%2C245 326w, https://i0.wp.com/wrbbradio.org/wp-content/uploads/2018/02/FullSizeRender-2.jpg?resize=80%2C60 80w, https://i0.wp.com/wrbbradio.org/wp-content/uploads/2018/02/FullSizeRender-2.jpg?zoom=2&amp;resize=80%2C60 160w, https://i0.wp.com/wrbbradio.org/wp-content/uploads/2018/02/FullSizeRender-2.jpg?zoom=3&amp;resize=80%2C60 240w" sizes="(max-width: 80px) 100vw, 80px" /><span>Previous</span><p>New Music Mondays | 02.19.18</p></a></div>
</nav>
<section class="mh-related-content">
<h3 class="mh-widget-title mh-related-content-title">
<span class="mh-widget-title-inner">Related Articles</span></h3>
<div class="mh-related-wrap mh-row clearfix">
<article class="post-4875 format-standard mh-col-1-3 mh-posts-grid-item clearfix">
	<figure class="mh-posts-grid-thumb">
		<a class="mh-thumb-icon mh-thumb-icon-small-mobile" href="http://wrbbradio.org/2016/12/07/sad13-releases-full-length-slugger/" title="Sad13 Releases Full-Length &#8220;Slugger&#8221;"><img width="326" height="245" src="https://i0.wp.com/wrbbradio.org/wp-content/uploads/2016/12/slugger.jpg?resize=326%2C245" class="attachment-mh-magazine-medium size-mh-magazine-medium wp-post-image" alt="" srcset="https://i0.wp.com/wrbbradio.org/wp-content/uploads/2016/12/slugger.jpg?resize=678%2C509 678w, https://i0.wp.com/wrbbradio.org/wp-content/uploads/2016/12/slugger.jpg?resize=326%2C245 326w, https://i0.wp.com/wrbbradio.org/wp-content/uploads/2016/12/slugger.jpg?resize=80%2C60 80w, https://i0.wp.com/wrbbradio.org/wp-content/uploads/2016/12/slugger.jpg?zoom=3&amp;resize=326%2C245 978w" sizes="(max-width: 326px) 100vw, 326px" />		</a>
		<div class="mh-image-caption mh-posts-grid-caption">
			Album Reviews		</div>
	</figure>
	<h3 class="mh-posts-grid-title">
		<a href="http://wrbbradio.org/2016/12/07/sad13-releases-full-length-slugger/" title="Sad13 Releases Full-Length &#8220;Slugger&#8221;" rel="bookmark">
			Sad13 Releases Full-Length &#8220;Slugger&#8221;		</a>
	</h3>
	<div class="mh-meta mh-posts-grid-meta">
		<span class="mh-meta-date updated"><i class="fa fa-clock-o"></i>December 7, 2016</span>
<span class="mh-meta-author author vcard"><i class="fa fa-user"></i><a class="fn" href="http://wrbbradio.org/author/caroline-smith/">Caroline Smith</a></span>
	</div>
</article><article class="post-7400 format-standard mh-col-1-3 mh-posts-grid-item clearfix">
	<figure class="mh-posts-grid-thumb">
		<a class="mh-thumb-icon mh-thumb-icon-small-mobile" href="http://wrbbradio.org/2018/02/02/tune-yards-releases-full-length-i-can-feel-you-creep-into-my-private-life/" title="tUnE-yArDs releases full-length &#8216;I Can Feel You Creep Into My Private Life&#8217;"><img width="326" height="245" src="https://i0.wp.com/wrbbradio.org/wp-content/uploads/2018/01/tune-yards-i-can-feel-you-creep-into-my-private-life-artwork.jpg?resize=326%2C245" class="attachment-mh-magazine-medium size-mh-magazine-medium wp-post-image" alt="" srcset="https://i0.wp.com/wrbbradio.org/wp-content/uploads/2018/01/tune-yards-i-can-feel-you-creep-into-my-private-life-artwork.jpg?resize=678%2C509 678w, https://i0.wp.com/wrbbradio.org/wp-content/uploads/2018/01/tune-yards-i-can-feel-you-creep-into-my-private-life-artwork.jpg?resize=326%2C245 326w, https://i0.wp.com/wrbbradio.org/wp-content/uploads/2018/01/tune-yards-i-can-feel-you-creep-into-my-private-life-artwork.jpg?resize=80%2C60 80w" sizes="(max-width: 326px) 100vw, 326px" />		</a>
		<div class="mh-image-caption mh-posts-grid-caption">
			Album Reviews		</div>
	</figure>
	<h3 class="mh-posts-grid-title">
		<a href="http://wrbbradio.org/2018/02/02/tune-yards-releases-full-length-i-can-feel-you-creep-into-my-private-life/" title="tUnE-yArDs releases full-length &#8216;I Can Feel You Creep Into My Private Life&#8217;" rel="bookmark">
			tUnE-yArDs releases full-length &#8216;I Can Feel You Creep Into My Private Life&#8217;		</a>
	</h3>
	<div class="mh-meta mh-posts-grid-meta">
		<span class="mh-meta-date updated"><i class="fa fa-clock-o"></i>February 2, 2018</span>
<span class="mh-meta-author author vcard"><i class="fa fa-user"></i><a class="fn" href="http://wrbbradio.org/author/caroline-smith/">Caroline Smith</a></span>
	</div>
</article><article class="post-4025 format-standard mh-col-1-3 mh-posts-grid-item clearfix">
	<figure class="mh-posts-grid-thumb">
		<a class="mh-thumb-icon mh-thumb-icon-small-mobile" href="http://wrbbradio.org/2016/10/04/thomston-releases-debut-full-length-topograph/" title="Thomston Releases Debut Full-Length &#8216;Topograph&#8217;"><img width="326" height="245" src="https://i1.wp.com/wrbbradio.org/wp-content/uploads/2016/10/IMG_4170-min.jpg?resize=326%2C245" class="attachment-mh-magazine-medium size-mh-magazine-medium wp-post-image" alt="" srcset="https://i1.wp.com/wrbbradio.org/wp-content/uploads/2016/10/IMG_4170-min.jpg?resize=678%2C509 678w, https://i1.wp.com/wrbbradio.org/wp-content/uploads/2016/10/IMG_4170-min.jpg?resize=326%2C245 326w, https://i1.wp.com/wrbbradio.org/wp-content/uploads/2016/10/IMG_4170-min.jpg?resize=80%2C60 80w, https://i1.wp.com/wrbbradio.org/wp-content/uploads/2016/10/IMG_4170-min.jpg?zoom=3&amp;resize=326%2C245 978w" sizes="(max-width: 326px) 100vw, 326px" />		</a>
		<div class="mh-image-caption mh-posts-grid-caption">
			Album Reviews		</div>
	</figure>
	<h3 class="mh-posts-grid-title">
		<a href="http://wrbbradio.org/2016/10/04/thomston-releases-debut-full-length-topograph/" title="Thomston Releases Debut Full-Length &#8216;Topograph&#8217;" rel="bookmark">
			Thomston Releases Debut Full-Length &#8216;Topograph&#8217;		</a>
	</h3>
	<div class="mh-meta mh-posts-grid-meta">
		<span class="mh-meta-date updated"><i class="fa fa-clock-o"></i>October 4, 2016</span>
<span class="mh-meta-author author vcard"><i class="fa fa-user"></i><a class="fn" href="http://wrbbradio.org/author/nicole-piker/">Nicole Piker</a></span>
	</div>
</article></div>
</section>
		<h4 id="mh-comments" class="mh-widget-title mh-comment-form-title">
			<span class="mh-widget-title-inner">
				Be the first to comment			</span>
		</h4>	<div id="respond" class="comment-respond">
		<h3 id="reply-title" class="comment-reply-title">Leave a Reply <small><a rel="nofollow" id="cancel-comment-reply-link" href="/2018/02/20/rhye-releases-full-length-blood/#respond" style="display:none;">Cancel reply</a></small></h3>			<form action="http://wrbbradio.org/wp-comments-post.php" method="post" id="commentform" class="comment-form" novalidate>
				<p class="comment-notes">Your email address will not be published.</p><p class="comment-form-comment"><label for="comment">Comment</label><br/><textarea id="comment" name="comment" cols="45" rows="5" aria-required="true"></textarea></p><p class="comment-form-author"><label for="author">Name </label><br/><input id="author" name="author" type="text" value="" size="30" /></p>
<p class="comment-form-email"><label for="email">Email </label><br/><input id="email" name="email" type="text" value="" size="30" /></p>
<p class="comment-form-url"><label for="url">Website</label><br/><input id="url" name="url" type="text" value="" size="30" /></p>
<!-- MailChimp for WordPress v4.1.11 - https://mc4wp.com/ --><input type="hidden" name="_mc4wp_subscribe_wp-comment-form" value="0" /><p class="mc4wp-checkbox mc4wp-checkbox-wp-comment-form"><label><input type="checkbox" name="_mc4wp_subscribe_wp-comment-form" value="1" checked="checked" /><span>Sign me up for the newsletter!</span></label></p><!-- / MailChimp for WordPress --><p class="form-submit"><input name="submit" type="submit" id="submit" class="submit" value="Post Comment" /> <input type='hidden' name='comment_post_ID' value='7506' id='comment_post_ID' />
<input type='hidden' name='comment_parent' id='comment_parent' value='0' />
</p><p style="display: none;"><input type="hidden" id="akismet_comment_nonce" name="akismet_comment_nonce" value="362a855b53" /></p><p class="comment-subscription-form"><input type="checkbox" name="subscribe_comments" id="subscribe_comments" value="subscribe" style="width: auto; -moz-appearance: checkbox; -webkit-appearance: checkbox;" /> <label class="subscribe-label" id="subscribe-label" for="subscribe_comments">Notify me of follow-up comments by email.</label></p><p class="comment-subscription-form"><input type="checkbox" name="subscribe_blog" id="subscribe_blog" value="subscribe" style="width: auto; -moz-appearance: checkbox; -webkit-appearance: checkbox;" /> <label class="subscribe-label" id="subscribe-blog-label" for="subscribe_blog">Notify me of new posts by email.</label></p><p style="display: none;"><input type="hidden" id="ak_js" name="ak_js" value="9"/></p>			</form>
			</div><!-- #respond -->
			</div>
			</div>
    </div>

<div class="mh-copyright-wrap">
	<div class="mh-container mh-container-inner clearfix">
		<p class="mh-copyright">Copyright © WRBB 104.9 FM</p>
	</div>
</div>
<style type="text/css">.wonderpluginaudio { max-width:inherit !important;}  .amazingaudioplayer-mark { display:none !important;}</style><style type="text/css">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</style><div class="wonderpluginaudio" id="wonderpluginaudio-1" data-audioplayerid="1" data-width="" data-height="40" data-skin="barwhitetitle" data-autoplay="false" data-random="false" data-forceflash="false" data-forcehtml5="false" data-autoresize="true" data-responsive="true" data-showtracklist="false" data-showprogress="true" data-showprevnext="false" data-showloop="false" data-showloading="false" data-enablega="false" data-titleinbarscroll="false" data-donotinit="false" data-addinitscript="true" data-loop="1" data-tracklistitem="10" data-titleinbarwidth="80" data-gatrackingid="" data-jsfolder="http://wrbbradio.org/wp-content/plugins/wonderplugin-audio/engine/" style="display:block;position:relative;margin:0 auto;width:100%;height:40px;"><ul class="amazingaudioplayer-audios" style="display:none;"><li data-artist="" data-title="Listen Live" data-album="" data-info="" data-image="" data-live="true"><div class="amazingaudioplayer-source" data-src="http://129.10.161.130:8000/" data-type="audio/mpeg" ></div><div class="amazingaudioplayer-source" data-src="http://129.10.161.130:8000/" data-type="audio/ogg" ></div></li></ul><div class="wonderplugin-engine"><a href="http://www.wonderplugin.com/wordpress-audio-player/" title="WordPress Audio Player">WordPress Audio Player</a></div></div><script>jQuery(document).ready(function(){jQuery(".wonderplugin-engine").css({display:"none"});jQuery(".wonderpluginaudio").wonderpluginaudio({forceinit:true});});</script></div>
  </div>
</div>
<a href="#" class="mh-back-to-top"><i class="fa fa-chevron-up"></i></a>
</div><!-- .mh-container-outer -->
	<div style="display:none">
	</div>
<script type='text/javascript' src='http://wrbbradio.org/wp-content/plugins/mailchimp-wp/assets/pagecount.min.js?ver=2.1.0'></script>
<script type='text/javascript' src='http://wrbbradio.org/wp-content/plugins/jetpack/modules/photon/photon.js?ver=20130122'></script>
<script type='text/javascript' src='https://s0.wp.com/wp-content/js/devicepx-jetpack.js?ver=201808'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var jpfbembed = {"appid":"249643311490","locale":"en_US"};
/* ]]> */
</script>
<script type='text/javascript' src='http://wrbbradio.org/wp-content/plugins/jetpack/_inc/facebook-embed.js'></script>
<script type='text/javascript' src='http://wrbbradio.org/wp-content/plugins/jetpack/_inc/twitter-timeline.js?ver=4.0.0'></script>
<script type='text/javascript' src='http://wrbbradio.org/wp-includes/js/wp-embed.min.js?ver=4.8.5'></script>
<script async="async" type='text/javascript' src='http://wrbbradio.org/wp-content/plugins/akismet/_inc/form.js?ver=4.0.1'></script>
<script type='text/javascript' src='https://stats.wp.com/e-201808.js' async defer></script>
<script type='text/javascript'>
	_stq = window._stq || [];
	_stq.push([ 'view', {v:'ext',j:'1:5.5.1',blog:'60537633',post:'7506',tz:'-5',srv:'wrbbradio.org'} ]);
	_stq.push([ 'clickTrackerInit', '60537633', '7506' ]);
</script>
</body>
</html>