<!DOCTYPE html>
<html lang="en-US">

<head>
    <meta charset="UTF-8">
    <meta http-equiv="X-UA-Compatible" content="IE=edge">
    <meta name="viewport" content="width=device-width, initial-scale=1, shrink-to-fit=no">
    <meta name="mobile-web-app-capable" content="yes">
    <meta name="apple-mobile-web-app-capable" content="yes">
    <meta name="apple-mobile-web-app-title"
        content="WRBB 104.9 FM - We Dare You To Listen">
    <link rel="profile" href="http://gmpg.org/xfn/11">
    <link rel="stylesheet" type="text/css"
        href="//fonts.googleapis.com/css?family=Playfair+Display"/>
    <link rel="pingback" href="https://wrbbradio.org/xmlrpc.php">
    <link rel="stylesheet"
        href="https://stackpath.bootstrapcdn.com/bootstrap/4.1.3/css/bootstrap.min.css"
        integrity="sha384-MCw98/SFnGE8fJT3GXwEOngsV7Zt27NXFoaoApmYm81iuXoPkFOJwJ8ERdknLPMO"
        crossorigin="anonymous">
    <title>LLVX’s IT’S THE VISIONS YOU PUT ON US is an angry inhalation &#8211; WRBB 104.9 FM</title>
<meta name='robots' content='max-image-preview:large' />
<link rel='dns-prefetch' href='//proxy.radiojar.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="WRBB 104.9 FM &raquo; Feed" href="https://wrbbradio.org/feed/" />
<link rel="alternate" type="application/rss+xml" title="WRBB 104.9 FM &raquo; Comments Feed" href="https://wrbbradio.org/comments/feed/" />
<link rel="alternate" type="application/rss+xml" title="WRBB 104.9 FM &raquo; LLVX’s IT’S THE VISIONS YOU PUT ON US is an angry inhalation Comments Feed" href="https://wrbbradio.org/2022/02/23/llvxs-its-the-visions-you-put-on-us-is-an-angry-inhalation/feed/" />
<script type="text/javascript">
window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/13.1.0\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/13.1.0\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/wrbbradio.org\/wp-includes\/js\/wp-emoji-release.min.js?ver=5.9.1"}};
/*! This file is auto-generated */
!function(e,a,t){var n,r,o,i=a.createElement("canvas"),p=i.getContext&&i.getContext("2d");function s(e,t){var a=String.fromCharCode;p.clearRect(0,0,i.width,i.height),p.fillText(a.apply(this,e),0,0);e=i.toDataURL();return p.clearRect(0,0,i.width,i.height),p.fillText(a.apply(this,t),0,0),e===i.toDataURL()}function c(e){var t=a.createElement("script");t.src=e,t.defer=t.type="text/javascript",a.getElementsByTagName("head")[0].appendChild(t)}for(o=Array("flag","emoji"),t.supports={everything:!0,everythingExceptFlag:!0},r=0;r<o.length;r++)t.supports[o[r]]=function(e){if(!p||!p.fillText)return!1;switch(p.textBaseline="top",p.font="600 32px Arial",e){case"flag":return s([127987,65039,8205,9895,65039],[127987,65039,8203,9895,65039])?!1:!s([55356,56826,55356,56819],[55356,56826,8203,55356,56819])&&!s([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]);case"emoji":return!s([10084,65039,8205,55357,56613],[10084,65039,8203,55357,56613])}return!1}(o[r]),t.supports.everything=t.supports.everything&&t.supports[o[r]],"flag"!==o[r]&&(t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&t.supports[o[r]]);t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&!t.supports.flag,t.DOMReady=!1,t.readyCallback=function(){t.DOMReady=!0},t.supports.everything||(n=function(){t.readyCallback()},a.addEventListener?(a.addEventListener("DOMContentLoaded",n,!1),e.addEventListener("load",n,!1)):(e.attachEvent("onload",n),a.attachEvent("onreadystatechange",function(){"complete"===a.readyState&&t.readyCallback()})),(n=t.source||{}).concatemoji?c(n.concatemoji):n.wpemoji&&n.twemoji&&(c(n.twemoji),c(n.wpemoji)))}(window,document,window._wpemojiSettings);
</script>
<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 0.07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
	<link rel='stylesheet' id='wp-block-library-css'  href='https://wrbbradio.org/wp-includes/css/dist/block-library/style.min.css?ver=5.9.1' type='text/css' media='all' />
<style id='global-styles-inline-css' type='text/css'>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</style>
<link rel='stylesheet' id='radiojar-css'  href='//proxy.radiojar.com/wrappers/api-plugins/v1/css/player.css?ver=5.9.1' type='text/css' media='all' />
<style id='radiojar-inline-css' type='text/css'>
#rj-player .rjp-player-container .jp-play,#rj-player .rjp-player-container .jp-pause {background:#0a0a0a;color:#ffffff;}#rj-player .rjp-player-container .jp-mute, #rj-player .rjp-player-container .jp-unmute {background:#cc3d3d;color:#ffffff;}#rj-player .rjp-player-container .jp-volume-bar-wrapper {background:#cc3d3d;}#rj-player .rjp-player-container .jp-volume-bar-value {background:#ffffff;}#rj-player .rjp-player-container {background: none;}
</style>
<link rel='stylesheet' id='h5p-plugin-styles-css'  href='https://wrbbradio.org/wp-content/plugins/h5p/h5p-php-library/styles/h5p.css?ver=1.15.4' type='text/css' media='all' />
<link rel='stylesheet' id='understrap-styles-css'  href='https://wrbbradio.org/wp-content/themes/WRBB-Site/css/theme.min.css?ver=0.0.0.1.1631062495' type='text/css' media='all' />
<script type='text/javascript' id='jquery-core-js-extra'>
/* <![CDATA[ */
var php_vars = {"url":"https:\/\/wrbbradio.org\/wp-content\/themes\/WRBB-Site"};
/* ]]> */
</script>
<script type='text/javascript' src='https://wrbbradio.org/wp-includes/js/jquery/jquery.min.js?ver=3.6.0' id='jquery-core-js'></script>
<script type='text/javascript' src='https://wrbbradio.org/wp-includes/js/jquery/jquery-migrate.min.js?ver=3.3.2' id='jquery-migrate-js'></script>
<script type='text/javascript' src='https://wrbbradio.org/wp-content/plugins/wonderplugin-audio/engine/wonderpluginaudioskins.js?ver=5.2' id='wonderplugin-audio-skins-script-js'></script>
<script type='text/javascript' src='https://wrbbradio.org/wp-content/plugins/wonderplugin-audio/engine/wonderpluginaudio.js?ver=5.2' id='wonderplugin-audio-script-js'></script>
<link rel="https://api.w.org/" href="https://wrbbradio.org/wp-json/" /><link rel="alternate" type="application/json" href="https://wrbbradio.org/wp-json/wp/v2/posts/67739" /><link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://wrbbradio.org/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://wrbbradio.org/wp-includes/wlwmanifest.xml" /> 
<meta name="generator" content="WordPress 5.9.1" />
<link rel="canonical" href="https://wrbbradio.org/2022/02/23/llvxs-its-the-visions-you-put-on-us-is-an-angry-inhalation/" />
<link rel='shortlink' href='https://wrbbradio.org/?p=67739' />
<link rel="alternate" type="application/json+oembed" href="https://wrbbradio.org/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwrbbradio.org%2F2022%2F02%2F23%2Fllvxs-its-the-visions-you-put-on-us-is-an-angry-inhalation%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://wrbbradio.org/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwrbbradio.org%2F2022%2F02%2F23%2Fllvxs-its-the-visions-you-put-on-us-is-an-angry-inhalation%2F&#038;format=xml" />
<link rel="icon" href="https://wrbbradio.org/wp-content/uploads/2018/05/cropped-blackred-w-white-SQUARE-1-32x32.png" sizes="32x32" />
<link rel="icon" href="https://wrbbradio.org/wp-content/uploads/2018/05/cropped-blackred-w-white-SQUARE-1-192x192.png" sizes="192x192" />
<link rel="apple-touch-icon" href="https://wrbbradio.org/wp-content/uploads/2018/05/cropped-blackred-w-white-SQUARE-1-180x180.png" />
<meta name="msapplication-TileImage" content="https://wrbbradio.org/wp-content/uploads/2018/05/cropped-blackred-w-white-SQUARE-1-270x270.png" />
    <!-- AJAX-ify all links -->
    <script
        src="http://cdnjs.cloudflare.com/ajax/libs/jquery-scrollTo/2.1.2/jquery.scrollTo.min.js"
    ></script>
    <!-- History.js -->
    <script
        src="http://browserstate.github.io/history.js/scripts/bundled/html4+html5/jquery.history.js"
    ></script>

</head>

<body class="post-template-default single single-post postid-67739 single-format-standard group-blog">

<div class="hfeed site" id="page">
    <div class="header">

        <!-- ******************* The Navbar Area ******************* -->
        <div id="wrapper-navbar" itemscope itemtype="http://schema.org/WebSite" class="wrbb-navbar display-none">

            <div class="header-logo">
                <a href="https://wrbbradio.org/">
                    <img alt="white and red logo"
                         src="https://wrbbradio.org/wp-content/themes/WRBB-Site/src/img/white-w-red.png"/>
                </a>
            </div>

            <form method="get" id="searchform" class="searchform" action="https://wrbbradio.org/" role="search">

	<div class="d-inline-flex" id="search-container">

		<input class="field form-control" id="search-input" name="s" type="text"
			placeholder="Search &hellip;" value="">
        <i class="fa fa-search"></i>

	</div>
</form>


            <a class="skip-link screen-reader-text sr-only"
               href="#content">Skip to content</a>


            <nav class="navbar-expand-md navbar-dark">

                <button class="navbar-toggler" type="button" data-toggle="collapse"
                        data-target="#navbarNavDropdown" aria-controls="navbarNavDropdown"
                        aria-expanded="false" aria-label="Toggle navigation">
                    <span class="navbar-toggler-icon"></span>
                </button>

                <!-- The WordPress Menu goes here -->
                <div class="menu-menu-1-container"><ul id="menu-menu-1" class="navbar-nav wrbb-menu"><li itemscope="itemscope" itemtype="https://www.schema.org/SiteNavigationElement" id="menu-item-5402" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children dropdown menu-item-5402 nav-item"><a title="on-air." href="#" aria-haspopup="true" aria-expanded="false" class="dropdown-toggle nav-link h4" id="menu-item-5402">on-air.</a>
<ul class="dropdown-content" aria-labelledby="menu-item-5402" id="menu-item-5402" role="menu">
	<li itemscope="itemscope" itemtype="https://www.schema.org/SiteNavigationElement" id="menu-item-7344" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-7344 nav-item"><a title="on-air schedule." href="https://wrbbradio.org/schedule/" class="dropdown-item">on-air schedule.</a></li>
	<li itemscope="itemscope" itemtype="https://www.schema.org/SiteNavigationElement" id="menu-item-66968" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-66968 nav-item"><a title="dj show bios." href="https://wrbbradio.org/dj-show-menu/" class="dropdown-item">dj show bios.</a></li>
	<li itemscope="itemscope" itemtype="https://www.schema.org/SiteNavigationElement" id="menu-item-4810" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-4810 nav-item"><a title="dj report form." href="https://wrbbradio.org/dj-report-form/" class="dropdown-item">dj report form.</a></li>
	<li itemscope="itemscope" itemtype="https://www.schema.org/SiteNavigationElement" id="menu-item-9410" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-9410 nav-item"><a title="rules and policies." target="_blank" href="http://wrbbradio.org/wp-content/uploads/2018/09/Rules-and-Policies-2018-2019.pdf" class="dropdown-item">rules and policies.</a></li>
</ul>
</li>
<li itemscope="itemscope" itemtype="https://www.schema.org/SiteNavigationElement" id="menu-item-66987" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children dropdown menu-item-66987 nav-item"><a title="features." href="https://wrbbradio.org/feature-main-page/" aria-haspopup="true" aria-expanded="false" class="dropdown-toggle nav-link h4" id="menu-item-66987">features.</a>
<ul class="dropdown-content" aria-labelledby="menu-item-66987" id="menu-item-66987" role="menu">
	<li itemscope="itemscope" itemtype="https://www.schema.org/SiteNavigationElement" id="menu-item-5350" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-5350 nav-item"><a title="interviews." href="https://wrbbradio.org/category/feature/interview/" class="dropdown-item">interviews.</a></li>
	<li itemscope="itemscope" itemtype="https://www.schema.org/SiteNavigationElement" id="menu-item-5996" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-5996 nav-item"><a title="editorials." href="https://wrbbradio.org/category/feature/editorial/" class="dropdown-item">editorials.</a></li>
	<li itemscope="itemscope" itemtype="https://www.schema.org/SiteNavigationElement" id="menu-item-5918" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-5918 nav-item"><a title="new music mondays." href="https://wrbbradio.org/category/new-music-mondays/" class="dropdown-item">new music mondays.</a></li>
	<li itemscope="itemscope" itemtype="https://www.schema.org/SiteNavigationElement" id="menu-item-5400" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-5400 nav-item"><a title="playlists." href="https://wrbbradio.org/category/playlists/" class="dropdown-item">playlists.</a></li>
</ul>
</li>
<li itemscope="itemscope" itemtype="https://www.schema.org/SiteNavigationElement" id="menu-item-66986" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children dropdown menu-item-66986 nav-item"><a title="reviews." href="https://wrbbradio.org/review-main-page/" aria-haspopup="true" aria-expanded="false" class="dropdown-toggle nav-link h4" id="menu-item-66986">reviews.</a>
<ul class="dropdown-content" aria-labelledby="menu-item-66986" id="menu-item-66986" role="menu">
	<li itemscope="itemscope" itemtype="https://www.schema.org/SiteNavigationElement" id="menu-item-4104" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent active menu-item-4104 nav-item"><a title="album reviews." href="https://wrbbradio.org/category/review/album-review/" class="dropdown-item">album reviews.</a></li>
	<li itemscope="itemscope" itemtype="https://www.schema.org/SiteNavigationElement" id="menu-item-4103" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-4103 nav-item"><a title="show reviews." href="https://wrbbradio.org/category/review/show-review/" class="dropdown-item">show reviews.</a></li>
	<li itemscope="itemscope" itemtype="https://www.schema.org/SiteNavigationElement" id="menu-item-4105" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-4105 nav-item"><a title="single reviews." href="https://wrbbradio.org/category/single-review/" class="dropdown-item">single reviews.</a></li>
	<li itemscope="itemscope" itemtype="https://www.schema.org/SiteNavigationElement" id="menu-item-66977" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-66977 nav-item"><a title="photos." href="https://wrbbradio.org/photos/" class="dropdown-item">photos.</a></li>
</ul>
</li>
<li itemscope="itemscope" itemtype="https://www.schema.org/SiteNavigationElement" id="menu-item-66971" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children dropdown menu-item-66971 nav-item"><a title="podcasts." href="https://wrbbradio.org/podcast-home-2/" aria-haspopup="true" aria-expanded="false" class="dropdown-toggle nav-link h4" id="menu-item-66971">podcasts.</a>
<ul class="dropdown-content" aria-labelledby="menu-item-66971" id="menu-item-66971" role="menu">
	<li itemscope="itemscope" itemtype="https://www.schema.org/SiteNavigationElement" id="menu-item-10345" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-10345 nav-item"><a title="NU &amp; Impodcast" href="https://wrbbradio.org/category/podcast/nu-impodcast/" class="dropdown-item">NU &amp; Impodcast</a></li>
	<li itemscope="itemscope" itemtype="https://www.schema.org/SiteNavigationElement" id="menu-item-10344" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-10344 nav-item"><a title="IRC Podcast" href="https://wrbbradio.org/category/podcast/irc-podcast/" class="dropdown-item">IRC Podcast</a></li>
	<li itemscope="itemscope" itemtype="https://www.schema.org/SiteNavigationElement" id="menu-item-10340" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-10340 nav-item"><a title="Black In Boston" href="https://wrbbradio.org/category/podcast/black-in-boston/" class="dropdown-item">Black In Boston</a></li>
	<li itemscope="itemscope" itemtype="https://www.schema.org/SiteNavigationElement" id="menu-item-10342" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-10342 nav-item"><a title="Brainwaves" href="https://wrbbradio.org/category/podcast/brainwaves/" class="dropdown-item">Brainwaves</a></li>
	<li itemscope="itemscope" itemtype="https://www.schema.org/SiteNavigationElement" id="menu-item-10346" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-10346 nav-item"><a title="NU Politics" href="https://wrbbradio.org/category/podcast/nupolitics/" class="dropdown-item">NU Politics</a></li>
	<li itemscope="itemscope" itemtype="https://www.schema.org/SiteNavigationElement" id="menu-item-10343" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-10343 nav-item"><a title="huNU" href="https://wrbbradio.org/category/podcast/hu-nu/" class="dropdown-item">huNU</a></li>
	<li itemscope="itemscope" itemtype="https://www.schema.org/SiteNavigationElement" id="menu-item-10339" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-10339 nav-item"><a title="360 Huntington" href="https://wrbbradio.org/category/podcast/360-huntington/" class="dropdown-item">360 Huntington</a></li>
	<li itemscope="itemscope" itemtype="https://www.schema.org/SiteNavigationElement" id="menu-item-10357" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-10357 nav-item"><a title="Mind Over Matter" href="https://wrbbradio.org/category/podcast/mind-over-matter/" class="dropdown-item">Mind Over Matter</a></li>
</ul>
</li>
<li itemscope="itemscope" itemtype="https://www.schema.org/SiteNavigationElement" id="menu-item-5445" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-5445 nav-item"><a title="wrbb sports." target="_blank" href="http://www.wrbbsports.com/" class="nav-link h4">wrbb sports.</a></li>
<li itemscope="itemscope" itemtype="https://www.schema.org/SiteNavigationElement" id="menu-item-5404" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children dropdown menu-item-5404 nav-item"><a title="more." href="#" aria-haspopup="true" aria-expanded="false" class="dropdown-toggle nav-link h4" id="menu-item-5404">more.</a>
<ul class="dropdown-content" aria-labelledby="menu-item-5404" id="menu-item-5404" role="menu">
	<li itemscope="itemscope" itemtype="https://www.schema.org/SiteNavigationElement" id="menu-item-60" class="menu-item menu-item-type-post_type menu-item-object-page current-post-parent menu-item-60 nav-item"><a title="becoming a member." href="https://wrbbradio.org/membership/" class="dropdown-item">becoming a member.</a></li>
	<li itemscope="itemscope" itemtype="https://www.schema.org/SiteNavigationElement" id="menu-item-7256" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-7256 nav-item"><a title="show request form." href="https://wrbbradio.org/showrequest/" class="dropdown-item">show request form.</a></li>
	<li itemscope="itemscope" itemtype="https://www.schema.org/SiteNavigationElement" id="menu-item-66973" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-66973 nav-item"><a title="FAQs." href="https://wrbbradio.org/faq/" class="dropdown-item">FAQs.</a></li>
	<li itemscope="itemscope" itemtype="https://www.schema.org/SiteNavigationElement" id="menu-item-66972" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-66972 nav-item"><a title="contact us." href="https://wrbbradio.org/contact-us/" class="dropdown-item">contact us.</a></li>
</ul>
</li>
</ul></div>
            </nav><!-- .site-navigation -->


        </div><!-- #wrapper-navbar end -->

        <!-- ******************* Slider ******************* -->

        <!--Find slug of current page-->
        
        <!--Display slider with images taken from posts in that category if any of these pages
        indicated by slug-->
                    <!--Static image otherwise-->
            <div class="header-image-fullscreen">
                <img width="1200" height="767" src="https://wrbbradio.org/wp-content/uploads/2022/02/AR-LLVX-1.jpg" class="attachment-full size-full wp-post-image" alt="" loading="lazy" srcset="https://wrbbradio.org/wp-content/uploads/2022/02/AR-LLVX-1.jpg 1200w, https://wrbbradio.org/wp-content/uploads/2022/02/AR-LLVX-1-300x192.jpg 300w, https://wrbbradio.org/wp-content/uploads/2022/02/AR-LLVX-1-1024x655.jpg 1024w, https://wrbbradio.org/wp-content/uploads/2022/02/AR-LLVX-1-150x96.jpg 150w" sizes="(max-width: 1200px) 100vw, 1200px" />            </div>
        

    </div> <!-- header -->
</div>

	
<div class="featured-image-caption">
	</div>

<div class="wrapper" id="single-wrapper">

    <div class="container" id="content" tabindex="-1">

        <hr class="header-line">

        <header class="entry-header">
            <h1 class="entry-title"><span class="article-title">LLVX’s <em>IT’S THE VISIONS YOU PUT ON US</em> is an angry inhalation</span></h1>            <div class="entry-meta">
                <p>by <span class="author vcard"><a class="url fn n" href="https://wrbbradio.org/author/annika-eske/">Annika Eske</a></span><span class="pipe"> | </span><time class="entry-date published updated" datetime="2022-02-23T06:39:34-05:00">February 23, 2022</time></p>            </div><!-- .entry-meta -->
        </header><!-- .entry-header -->

        <div class="row" id="post-content">

            <main class="site-main col-lg-8" id="post-main">

                
                    <article class="post-67739 post type-post status-publish format-standard has-post-thumbnail hentry category-album-review category-main-page-article category-review" id="post-67739">

	<div class="entry-content">

		
<h2 style="text-align: center;"><strong>LLVX</strong></h2>



<h2 style="text-align: center;"><em>IT&#8217;S THE VISIONS YOU PUT ON US</em></h2>



<h3 style="text-align: center;">SSANG SSANG · February 11, 2022</h3>



<div class="wp-block-image">
<figure class="aligncenter"><img class="wp-image-67033 aligncenter" src="http://wrbbradio.org/wp-content/uploads/2021/09/4-star-review.png" alt="" /></figure>
</div>
<hr class="wp-block-separator" />
<p><span style="font-weight: 400;">After their latest album, </span><i><span style="font-weight: 400;">Eyes</span></i><span style="font-weight: 400;">, the most recent EP from NYC- and Boston-based artist LLVX is something of an angry inhalation before the next full-length release. The EP, titled </span><i><span style="font-weight: 400;">IT’S THE VISIONS YOU PUT ON US</span></i><span style="font-weight: 400;">, is simmering with discontent and uneasiness that falls just before the point of boiling over. It features crisp production on the track “AM I COLD,” an unprompted and honest bout of dialogue in “ROYALTY,” and an ambient conclusion in “There Is No Greater Love &#8211; Mollified Mix.”</span></p>
<p><span style="font-weight: 400;">“AM I COLD” is a fitting start to the EP, as it samples from the song “Cold” off LLVX’s last album release. While it gives a nod to previous work, it also incorporates a fresh new sound as featured artists Olias. and ShojiZero rap over the familiar instrumental portion. While “Cold” was a brooding slow burn of a song, “AM I COLD” quickens the pace ever so slightly. It maintains a moody aura while also taking on an almost threatening quality. As can be said of the album as a whole, this track harbors pent-up anger that evokes a compelling sense of anticipation– when will we see this energy boil over?</span></p>
<p><span style="font-weight: 400;">After “AM I COLD,” the EP delves right into the spontaneous dialogue of “ROYALTY.” The narrator here seems to be having a conversation that then sparks a rant of sorts. The lyrics point out the layers of discrimination that exist even within oppressed communities. With a thoughtful and disappointed voice, LLVX appears to make the observation that just about every group of people silences some of their members, intentionally or not. At one point for example, “ROYALTY” brings up racism and sexism within the queer community, an already oppressed group of people. This ruminative train of thought does not necessarily offer up answers, but rather, seeks to shine some light on the fact that these problems exist and should be recognized in the first place. As the narration progresses in a stream-of-consciousness style, foreboding and rhythmic piano chords lurk in the background. These chords hint again at a sensation of pent-up anger, or energy waiting to be released. The grim undertones throughout this song give greater significance to the lighter piano melody at the conclusion of the song. The twinkling final notes seem to drift above the darkness that pervaded the rest of “ROYALTY,” as if to suggest that things don’t have to remain the way they are.</span></p>
<p><span style="font-weight: 400;">Finally, the EP ends with the 16-minute ambient track, “There Is No Greater Love &#8211; Mollified Mix.” The track is, in a sense, peaceful. However, it also has an undeniable eerie edge to it – perhaps owing to the chord choice but also because of the low, vibratory quality of the sounds used. The track feels as if the rumbling approach of some colossal ship has been transformed into a beautiful and slightly industrial soundscape. Essentially, the track comes across as a temporary respite from anger. With this tranquil conclusion, there is an implication that all of the barely restrained discontent of </span><i><span style="font-weight: 400;">IT’S THE VISIONS YOU PUT ON US</span></i><span style="font-weight: 400;">, will be untied in LLVX’s next music release.</span></p>
		
	</div><!-- .entry-content -->

</article><!-- #post-## -->
                    
<div class="comments-area" id="comments">

	
	
	
		<div id="respond" class="comment-respond">
		<h3 id="reply-title" class="comment-reply-title">Leave a Reply</h3><form action="https://wrbbradio.org/wp-comments-post.php" method="post" id="commentform" class="comment-form" novalidate><p class="comment-notes"><span id="email-notes">Your email address will not be published.</span> <span class="required-field-message" aria-hidden="true">Required fields are marked <span class="required" aria-hidden="true">*</span></span></p><div class="form-group comment-form-comment">
	    <label for="comment">Comment <span class="required">*</span></label>
	    <textarea class="form-control" id="comment" name="comment" aria-required="true" cols="45" rows="8"></textarea>
	    </div><div class="form-group comment-form-author"><label for="author">Name</label> <input class="form-control" id="author" name="author" type="text" value="" size="30"></div>
<div class="form-group comment-form-email"><label for="email">Email</label> <input class="form-control" id="email" name="email" type="email" value="" size="30"></div>
<div class="form-group comment-form-url"><label for="url">Website</label> <input class="form-control" id="url" name="url" type="url" value="" size="30"></div>
<div class="form-group form-check comment-form-cookies-consent"><input class="form-check-input" id="wp-comment-cookies-consent" name="wp-comment-cookies-consent" type="checkbox" value="yes" /> <label class="form-check-label" for="wp-comment-cookies-consent">Save my name, email, and website in this browser for the next time I comment</label></div>
<p class="form-submit"><input name="submit" type="submit" id="submit" class="btn btn-secondary" value="Post Comment" /> <input type='hidden' name='comment_post_ID' value='67739' id='comment_post_ID' />
<input type='hidden' name='comment_parent' id='comment_parent' value='0' />
</p><p style="display: none;"><input type="hidden" id="akismet_comment_nonce" name="akismet_comment_nonce" value="448f00b28e" /></p><p style="display: none !important;"><label>&#916;<textarea name="ak_hp_textarea" cols="45" rows="8" maxlength="100"></textarea></label><input type="hidden" id="ak_js_1" name="ak_js" value="29"/><script>document.getElementById( "ak_js_1" ).setAttribute( "value", ( new Date() ).getTime() );</script></p></form>	</div><!-- #respond -->
	
</div><!-- #comments -->

                
            </main><!-- #main -->

            <div class="col-lg-4 sidebar">

                <div class="spotify">
                    <div id= "tagline">
                        <h5><strong>
                            Listen to <em>IT’S THE VISIONS YOU PUT ON US</em>:                        </strong></h5>
                    </div>
                    <iframe style="border-radius:12px" src="https://open.spotify.com/embed/album/5r4Se73fAi05vDLuOLSasY?utm_source=generator" width="100%" height="380" frameBorder="0" allowfullscreen="" allow="autoplay; clipboard-write; encrypted-media; fullscreen; picture-in-picture"></iframe>                </div>

                <div class="socials">
                    <a href="https://twitter.com/wrbbradio" target="_blank">
                        <img src="https://wrbbradio.org/wp-content/themes/WRBB-Site/src/img/twitter.png" alt="Twitter"></a>
                    <a href="https://www.facebook.com/WRBBRadio/" target="_blank">
                        <img src="https://wrbbradio.org/wp-content/themes/WRBB-Site/src/img/facebook.png" alt="Facebook"></a>
                    <a href="https://www.instagram.com/wrbbradio/" target="_blank">
                        <img src="https://wrbbradio.org/wp-content/themes/WRBB-Site/src/img/instagram.png" alt="Instagram"></a>
                </div>

                            </div>
        </div><!-- .row -->

        
<!-- Get post ID of current page (in wordpress, page is a post) -->


    <!-- Container for entire related articles section -->
    <div class="related-articles-container">

        <h2 class="ra-title">related articles.</h2>

        <!-- Underline for related articles -->
        <hr class="header-line" id="ra-line">

        <!-- Wrapper for 3 related articles partitioned into columns -->
        <div>

            <div class="row ra-articles">

                
                    <div class="col-sm-4 related-article">
                        
<article class="post-67219 post type-post status-publish format-standard has-post-thumbnail hentry category-album-review category-main-page-article category-review" id="post-67219">

	<header class="entry-header">

        <div class="thumbnail-image">
		    <a href="https://wrbbradio.org/2021/10/24/on-his-latest-release-optimist-finneas-practices-humble-self-reflection/">
			    <img src="https://wrbbradio.org/wp-content/uploads/2021/10/AR-FINNEAS-1.png">
		    </a>
        </div>

		<div class="mpa-meta">
			<h5 class="thumbnail-title"><a href="https://wrbbradio.org/2021/10/24/on-his-latest-release-optimist-finneas-practices-humble-self-reflection/" rel="bookmark">On <em>Optimist</em>, FINNEAS practices humble self-reflection</a></h5><p id="mpa-date"> <time class="entry-date published" datetime="2021-10-24T18:37:19-04:00">October 24, 2021</time></p><p id="mpa-author"> by <span class="author vcard"><a class="url fn n" href="https://wrbbradio.org/author/riana-buchman/">Riana Buchman</a></span></p>		</div><!-- .entry-meta -->

	</header><!-- .entry-header -->

</article><!-- #post-## -->
                    </div>

                
                    <div class="col-sm-4 related-article">
                        
<article class="post-67365 post type-post status-publish format-standard has-post-thumbnail hentry category-album-review category-main-page-article category-review" id="post-67365">

	<header class="entry-header">

        <div class="thumbnail-image">
		    <a href="https://wrbbradio.org/2021/11/28/gracie-abrams-explores-her-fears-doubts-and-hopes-on-this-is-what-it-feels-like/">
			    <img src="https://wrbbradio.org/wp-content/uploads/2021/11/AR-Gracie-Abrams.jpg">
		    </a>
        </div>

		<div class="mpa-meta">
			<h5 class="thumbnail-title"><a href="https://wrbbradio.org/2021/11/28/gracie-abrams-explores-her-fears-doubts-and-hopes-on-this-is-what-it-feels-like/" rel="bookmark">Gracie Abrams explores her fears, doubts, and hopes on <em>This Is What It Feels Like</em></a></h5><p id="mpa-date"> <time class="entry-date published" datetime="2021-11-28T15:00:51-05:00">November 28, 2021</time></p><p id="mpa-author"> by <span class="author vcard"><a class="url fn n" href="https://wrbbradio.org/author/aidan-mcgovern/">Aidan McGovern</a></span></p>		</div><!-- .entry-meta -->

	</header><!-- .entry-header -->

</article><!-- #post-## -->
                    </div>

                
                    <div class="col-sm-4 related-article">
                        
<article class="post-3366 post type-post status-publish format-standard has-post-thumbnail hentry category-album-review" id="post-3366">

	<header class="entry-header">

        <div class="thumbnail-image">
		    <a href="https://wrbbradio.org/2016/02/26/album-review-i-think-i-have-a-problem-but-i-fuck-with-it-max-gertler/">
			    <img src="https://wrbbradio.org/wp-content/uploads/2016/02/artworks-000145097156-xwmzb3-t500x500.jpg">
		    </a>
        </div>

		<div class="mpa-meta">
			<h5 class="thumbnail-title"><a href="https://wrbbradio.org/2016/02/26/album-review-i-think-i-have-a-problem-but-i-fuck-with-it-max-gertler/" rel="bookmark">ALBUM REVIEW: I Think I Have a Problem, But I fuck With It &#8211; Max Gertler</a></h5><p id="mpa-date"> <time class="entry-date published" datetime="2016-02-26T20:43:49-05:00">February 26, 2016</time></p><p id="mpa-author"> by <span class="author vcard"><a class="url fn n" href="https://wrbbradio.org/author/wrbbmusic/">WRBB Media Team</a></span></p>		</div><!-- .entry-meta -->

	</header><!-- .entry-header -->

</article><!-- #post-## -->
                    </div>

                
            </div><!-- .row -->

        </div>

    </div><!-- .related-articles-container -->


    </div><!-- Container end -->
</div><!-- Wrapper end -->



<html>

	<head>
		<script src="https://kit.fontawesome.com/ef315d9147.js" crossorigin="anonymous"></script>
	</head>

	<div class="wrapper" id="wrapper-footer">

		<div class="container">

			<div class="row">

				<div class="col-md-12">

					<footer class="site-footer" id="colophon">

						<div class="site-info">

							<div class="social-media" style="text-align: center;">
                                <a href="https://www.facebook.com/WRBBRadio/"><i class="fab fa-facebook fa-lg"></i></a>
                                <a href="https://www.instagram.com/wrbbradio/"><i class="fab fa-instagram fa-lg"></i></a>
                                <a href="https://twitter.com/wrbbradio"><i class="fab fa-twitter fa-lg"></i></a>
                                <a href="https://open.spotify.com/user/pfe0l6pbdx8667wos0gwqtwx9?si=JsuhCoLER_mAmO2S_ppfMQ"><i class="fab fa-spotify fa-lg"></i></a>
							</div>

                            <br>

							<div class="row logo-articles">
                                                                <div class="col-lg-5 cat-links">
                                    <a href="https://wrbbradio.org/category/review/album-review/" class="cat-link">
                                        album reviews.
                                    </a>
                                    <a href="https://wrbbradio.org/category/review/show-review/" class="cat-link">
                                        show reviews.
                                    </a>
                                </div>
                                <div class="col-lg-2"
                                    <a href="http://wrbbradio.org/">
                                        <img src="https://wrbbradio.org/wp-content/themes/WRBB-Site/img/logo.png" class="logo" alt="WRBB Logo">
                                    </a>
                                </div>
                                <div class="col-lg-5 cat-links">
                                    <a href="https://wrbbradio.org/category/feature/editorial/" class="cat-link">
                                        editorials.
                                    </a>
                                    <a href="https://wrbbradio.org/category/feature/interview/" class="cat-link">
                                        interviews.
                                    </a>
                                </div>
							</div>

                            <br>
					
                            Proudly powered by <a href="http://wordpress.org/">WordPress</a>
                            and <a href="http://understrap.com">UnderStrap</a>.

						</div><!-- .site-info -->

					</footer><!-- #colophon -->

				</div><!--col end -->

			</div><!-- row end -->

		</div><!-- container end -->

	</div><!-- wrapper end -->

    
<div class="playerbar">
    <div class="player-controls">
        <div>
            <h3 class="player-text">Listen Live</h3>
            <div class="play-button">
                <i class="fas fa-play-circle fa-lg"></i>
            </div>
        </div>
        <div class="volume-controls">
            <i class="fa fa-volume-up fa-md" aria-hidden="true"></i>
            <label for='volume-slider'></label>
            <input id='volume-slider' type="range" min="1" max="100" step="1" value="50">
        </div>
    </div>
</div>

	</div><!-- #page we need this extra closing tag here -->

	<script type='text/javascript' src='https://wrbbradio.org/wp-content/themes/WRBB-Site/js/popper.min.js?ver=0.0.0.1' id='popper-scripts-js'></script>
<script type='text/javascript' src='https://wrbbradio.org/wp-content/themes/WRBB-Site/js/theme.min.js?ver=0.0.0.1.1643245086' id='understrap-scripts-js'></script>

</html>